电话对讲机配置好SIP相关账号信息,提交注册,电话对讲机显示注册失败。
1.2.适用型号
适用产品机型:所有电话对讲机 适用版本:适用机型的所有版本
1.3.适用对象
本文档适用于SIP帐号注册失败的用户
2.解决方案
2.1.选择问题类型
情境一:提交注册信息后提示注册超时
情境二:使用一段时间后提示注册超时
情境三:注册失败,返回错误码
情境四:电话对讲机使用一段时间后,突然掉线,网络不通。重启电话对讲机后,网络恢复
情境五:电话对讲机显示已注册,但SIP对讲服务器显示掉线,未注册
2.2.问题排查及解决方案
2.2.1提交注册信息后提示注册超时
1、问题现象:
电话对讲机设置好SIP相关参数,提交注册,电话对讲机显示“注册中...”,过一段时间显示为“注册超时”
2、可能原因:
电话对讲机发起注册请求后,一直没有收到服务器响应,导致注册超时。
①可能由于网络原因,电话对讲机和服务器网络不通,或者参数配置错误,比如:服务器地址和端口填写错误。
②账号异常被系统加入黑名单,一段时间内无法注册。在IMS系统下,当同一个账号频繁注册的时候,IMS会认为是恶意注册,一段时间内会禁止这个账号注册(比如:10分钟内,禁止该账号注册)。过一段时间就可以了。
③当电话对讲机在内网,注册到公网服务器时,服务器响应的包无法发送到内网电话对讲机上。
3、解决方案
①确认电话对讲机和服务器之间的网络是否正常,是否可以互相Ping通;同时确认设置的SIP账号参数是否正确,比如:地址和端口是否正确?
②等待一段时间再提交注册消息或服务器建立新的帐号,避免相同帐号反复注册到不同电话对讲机
③内网电话对讲机注册到公网服务器时,开启电话对讲机“rport”和“兼容特殊服务器”功能,提交注册。
2.2.2使用一段时间后提示注册超时
1、问题现象:
电话对讲机正常注册使用,使用一段时间后(一天左右),电话对讲机注册状态变为了“注册超时”。无法打接电话。需要重启重新注册,或者修改本地注册端口号后再注册,就可以注册成功。
2、可能原因:
一般这种现象会在使用某些路由器的环境下发生。原因是当路由器断电重启或者重新获得新的公网IP地址时,电话对讲机发出的包,通过路由器路由时,源地址依然是路由器之前的老地址,没有使用最新的公网IP地址,导致服务器的响应包,无法送达电话对讲机。导致注册超时。当电话对讲机重启,或者修改本地注册端口后,经过路由器的包,源地址就可以被路由器改写正确,注册成功。
3、解决方案:
在新firmware中,增加了使用本地SIP动态端口的机制。当电话对讲机注册超时或者失败时,电话对讲机下次重新注册时,会启用新的本地端口去注册。请登入官网下载最新版本或联系技术人员确认版本支持情况。
2.2.3注册失败,返回错误码
1、问题现象:
电话对讲机配置好SIP相关账号信息,提交注册,电话对讲机显示注册失败。
①返回错误码403
②返回错误码404
③返回错误码423
④返回错误码5xx
2、可能原因:
①一般表示用户名或密码错误,或者服务器Disable了这个账号。
②表示账号不存在。
③表示注册间隔太短。
④表示服务器故障。
3、解决方案:
①请重新检查用户名密码,联系管理员确认。
②联系管理员确认
③修改电话对讲机注册有效期,改长一点
④需要联系管理员确认
2.2.4电话对讲机使用一段时间后,突然注册掉线,网络不通
1、问题现象:
电话对讲机使用一段时间后,突然注册掉线,网络不通。重启电话对讲机后,网络恢复。
2、可能原因:
思科交换机或某些二层交换机存在对ARP老化时间的定义,跟我们电话对讲机系统定义使用的ARP老化时间有差别,可能会导致因交换机端老化时间到期而中断电话对讲机的网络连接。
3、解决方案:
确认升级电话对讲机系统到最新版本,支持手动设置ARP老化时间参数,登入电话对讲机WEB页面-网络-高级-ARP老化时间,配置修改1到N不等,单位为分钟。
2.2.5 电话对讲机显示已注册,但SIP对讲服务器显示掉线,未注册
1、问题现象:
电话对讲机显示已注册,但SIP对讲服务器显示掉线,未注册。
2、可能原因:
某些网络可能存在IP路由或者NAT保持,但SIP对讲服务器或者电话对讲机并未开启NATkeep alive,导致SIP注册请求响应后,无UDP的连接保持,结果NAT服务器通常在默认的UDP60秒保活后,移除了NAT连接。
3、解决方案:
登入电话对讲机的WEB界面---线路---高级设定—保持联机类型及保持联机周期,根据SIP服务器支持的模式,或者尝试选择为SIPOPTION或者UDP,保持联机周期的时间要小于60秒。
以上步骤中(本文档以X4U电话对讲机为例进行设置说明):
开启电话对讲机“rport”和“兼容特殊服务器”的方法:
进入电话对讲机WEB管理页面点击“线路”-“高级设定”--勾选“启用Rport”和“配置兼容特殊服务器”-点击页面底端的提交,如下图所示:
启用本地“端口更新”的方法:
进入电话对讲机WEB管理页面点击“线路”-“高级设定”--勾选“启用端口更新”-点击页面底端的提交,如下图所示:
修改电话对讲机“注册有效期”的方法:
进入电话对讲机WEB管理页面点击“线路”-“高级设定”--“注册有效期”–修改注册时间,点击页面底端的提交,如下图所示:
修改电话对讲机“ARP老化时间”的方法:
进入电话对讲机WEB管理页面点击“网络”-“高级”--“ARP老化时间”配置修改1到N不等(建议和交换机老化时间匹配)-点击页面底端的提交,如下图所示:
修改电话对讲机“保持联机类型”的方法:
进入电话对讲机WEB管理页面点击“线路”-“高级设定”--“保持联机类型”根据SIP服务器支持的模式,或者尝试选择为SIPOPTION或者UDP,点击页面底端的提交,如下图所示: